Free Delivery Easy Returns Secure Payments
Be inspired
  • Coffee Shots
  • Breakfast Collections

FAQs

Ask us a question.

Which smart phones/tablets can I use the De’Longhi Comfort app with?

The app is compatible with phones and tablets that can run the latest iOS (from 10.3 up) or Android (from 6 up) software.

The minimum versions requested are: Android 5 (Lollipop) and iOS 11.

Unfortunately, it is not compatible with either Fire or Windows smart devices.